Home News Contact Us Forum About Us Demos Products F.A.Q.
Shopping Cart
You currently have 0 items in your cart.


Recent Events
  • 18/11/2017 Black Friday is coming

    Don't wait BLACK FRIDAY, use FRIDAY17 coupon code to get 35% discount for all our extensions right now.

  • 05/09/2017 BIG Autumn SALE

    Use AUTUMN17 coupon code to buy our WordPress or Joomla! extensions with 25% discount. Hurry up! The offer is valid till 11 September.


2Checkout.com, Inc. is an authorized retailer of goods and services provided by ARI Soft. 2CheckOut




Follow us on twitter



Welcome, Guest
Please Login or Register.    Lost Password?

add css class not working?
(1 viewing) (1) Guest
Go to bottomPage: 1
TOPIC: add css class not working?
*
#43866
add css class not working? 4 Years, 3 Months ago Karma: 0
I put 3 slideshows inside an article, and they need to be styled differently.

One is full width at the top of the article.
Another should be floated left inside a paragraph.
Another should be floated right.

I try to add a class under: OPTIONS / Module Class Suffix, but the modules don't get the class in the article.

How to fix?
Last Edit: 2013/08/26 00:19 By stefyxz.
The administrator has disabled public write access.
 
#43867
Re:add css class not working? 4 Years, 3 Months ago Karma: 0
There is also another problem with adding the slideshow in the articles.
Each slideshow gets an empty paragraph just before: <p></p> before itself. This happen even when the tag {arislideshow moduleId="xxx"} is inside anther paragraph. This changes the intended layout.
How to avoid this???
Last Edit: 2013/08/26 00:18 By stefyxz.
The administrator has disabled public write access.
 
#43878
Re:add css class not working? 4 Years, 3 Months ago Karma: 670
Hello,

"Module Class Suffix" parameter are defined in Joomla! modules, but it is used by site templates when modules are loaded into module positions which are defined in site templates. This logic is used by Joomla! system.

In your case you can wrap plugin code with <DIV> element with specific CSS class to add custom styles.

About <P> tag, it is not added by the extension. We suppose the tag is added by WYSIWYG editor which you use in articles.

Regards,
ARI Soft
The administrator has disabled public write access.
 
#43903
Re:add css class not working? 4 Years, 3 Months ago Karma: 0
Thank you. I wish it was so simple, but unfortunately it does not work!

The module is already wrapped in a div (in ADVANCED OPTIONS, MODULE TAG), and it is supposed to have a class (from BASIC OPTIONS, MODULE CLASS SUFFIX).

The module just doesn't get any class. Other modules work, like slideshow CK, and they take their class as supposed.

I like your module better, it has much nicer transitions. But this doesn't work, I already tried as per your advice. It simply doesn't get any class!

Another problem: your module breaks other javascript plugins, they stop working when your module is loaded in the page. But they work properly when other slideshow plugins are loaded instead....

Any solution?
Last Edit: 2013/08/26 23:18 By stefyxz.
The administrator has disabled public write access.
 
#43904
Re:add css class not working? 4 Years, 3 Months ago Karma: 670
Where we can see the problem with other extensions?

Regards,
ARI Soft
The administrator has disabled public write access.
 
Go to topPage: 1